UP Board

The UP Board's key feature is that it is very close to the original Raspberry Pi dimensions. Well that and it has an Intel Quad 64 bit CPU with AES instructions based on the Atom core for low power consumption. However there are two issues which required some plastics re-engineering and a mod to the UP Board itself to integrate it into the PiCluster (does that make it an X86_64 cluster too?).

This board died. Its eMMC failed and never booted again. Various people tried to resurrect it but it never worked again. It was never replaced (.... by an Intel board at least, anyway).

Updated 2021.07.19 OS changed to Ubuntu

See the OS page for details

Firstly, there is a heatsink plate attached to the bottom of the board, not to mention the more obvious one on the top. This raises another, sort of irrelevant, issue: this thing gets hot!

Secondly, the power connector sticks out.

Because of the lower heatsink the carriage needed to have its guts removed to accommodate the board on its rails.

Then there's the issue of the 5V DC connector sticking out.

This required a mod to the main Desktop PiCluster body to push the left front leg inside to the left as far as possible. This turned out to be to the point where metal threaded rod would be exposed. Any further would require a complete reprint of the entire PiClusterr.

The modification to the UP Board was based on accepted practice for Mercedes Benz parts that don't fit. An old file was pressed in to service and the connector shaved down until it fitted through the gap.

Then after all that....

The battery was sticking up too high. It needed to be removed, the double sided tape peeled off and then the residual glue just holds it in place. As you can see there's a small gap in the bodies due in part to the excessive battery height.

It's now running Fedora 27 30 64 bit Server edition Ubuntu 20.04.2 64-bit Server Edition with Docker-ce loaded.

Booting the OS was a minor hiccup because this machine is UEFI only, so no netinstall which requires bios. A quick download later (2.6GB) and the OS image was here. "Burned" it on to a USB stick and bingo. Updated - see the OS page

It's now easily the HOTTEST credit card sized server in the rack. However, since Fedora has been loaded, it now runs cooler. After first firing it up it went to the UEFI command line where it used lots of power for whatever reason and got real hot.

How fast?

Well the only true way to detemine how fast a computer runs consists of loading Crypto currency mining software. A quick download of the Monero pool miner shows a hash rate of 23.4.

So where does that fit in the pecking order of things?

Well here's a table

Raspberry Pi3 5.5
UpBoard Intel(R) Atom(TM) x5-Z8350  CPU @ 1.44GHz 23.4
Intel(R) Xeon(R) CPU E3-1245 v5 @ 3.50GHz 146
NVidia GeForce GTX 1060 6GB 460

How hot?

I thought I'd get the temperature gauge out to measure exactly how hot the UPboard gets

Which, as it turns out, is not all that hot. Here's a Raspberry Pi 3 also running Crypto mining stuff. A temperature difference of only 8 degrees.

Having said that however, the Pi 3 has no heatsink at all. Quite miraculous really.

Updated 2022.03.15 UpBoard bricked

Yes, unfortunately after a move to a new central HQ located in another city, the UpBoard refused to come back to life. There are numerous posts on the web regarding this phenomenon with this version of the board. Alas I ran out of patience and simply replaced the board with an 8GB (twice the RAM) CM4 based board with NVMe. Dennis thinks it's related to the bios being corrupted in some way. It's now in his hands and he's going to attempt to reflash via SPI to the lastest firmware.

Power consumption for the entire cluster went down by quite a lot too.